Password Reset Emails not Received

Last Updated: Oct 18, 2024

Overview

The configuration test emails are coming through just fine, but when a user is invited to an organization or creates a change password ticket, the emails are not being received. The response from the Management Client has different ticket URLs, but no emails are being received. Both corporate email addresses and email addresses were used, but the issue persists. Other email flows are working, but password reset emails are not received.

This article details what could be the possible cause of this issue and how it can be resolved.

Applies To

  • Email
  • Password Reset

Cause

There could be a few possible causes. The first cause may be there is an issue with the email provider configuration, such as a non verified email address (SES and Sendgrid commonly have this error).

A second cause may be that the Management API password reset ticket endpoint is being used, expecting it to send an email, however this endpoint only generates a link and does not send an email. See this article: Create a password change ticket

A third possible cause for this issue could be that the admin is trying to reset a password for a non-Database connection which is not supported.

Finally, another possibility is that the ā€œchange password email templateā€ is disabled. This cannot be disabled through the Dashboard UI, but it can be disabled with the Management API. It is possible to retrieve the current settings with a GET to /api/v2/email-templates/reset_email to see if ā€œenabledā€: false and then PATCH it to change ā€œenabledā€ to true.

To troubleshoot the issue:

  • Check tenant logs for type:ā€œfnā€ logs, and for type:ā€œscprā€
  • Check the email providerā€™s logs if the tenant logs show the ā€˜scprā€™ log type. This log type (ā€˜scprā€™) confirms that the email was successfully delivered to the provider. By sharing the timestamp with the provider, they may be able to investigate further and provide insight into why the email has not appeared in the userā€™s inbox.

Solution

To trigger a password reset email outside of using the ā€œForgot passwordā€ link in Universal login, make a POST to this endpoint:

The Management API reset password ticket endpoint will NOT send an email and is instead intended to allow for custom password reset flows by sharing the ticket URL with the customer outside of Auth0:

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