Password reset emails not received

Problem Statement

The configuration test emails are coming through just fine, but when we invite a user to an organization or create a change password ticket, the emails are not being received. We are getting different ticket URLs from the response from Management Client, but no emails. We have tried both our corporate email addresses and also Gmail addresses. Other email flows are working, but password reset emails are not being received.

Symptoms

Other email flows are working, but password reset emails are not being received

Cause

A few reasons could cause this issue:

  • issue with your email provider configuration, such as a non-verified email address (SES and Sendgrid commonly have this error)

  • using the Management API password reset ticket endpoint, expecting it to send an email (which it doesn’t)

  • resetting a password for a non Database connection

  • Change password email template is disabled. This cannot be disabled through the Dashboard UI, but it can be disabled with the Management API. You can retrieve your current settings with a GET to /api/v2/email-templates/reset_email to see if “enabled”: false and then PATCH it to change “enabled” to true:

https://auth0.com/docs/api/management/v2#!/Email_Templates/put_email_templates_by_templateName

Solution

To trigger a password reset email outside of using the “Forgot password” link in Universal login, please make a POST to this endpoint:

The Management API reset password ticket endpoint will NOT send an email and is instead intended to allow for custom password reset flows by sharing the ticket URL with the customer outside of Auth0:

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