Auth0 Home Blog Docs

Issue with password reset mail not being sent



We are using Amazon SES as mail provider. Verification emails are going out, but reset password emails are NOT going out. Manually resetting passwords is not an option with which we can roll-out in production. This is a priority concern for us to migrate from our existing provider to Auth0.

CC: @arjunlal.bindulal


There was issue identified recently where disabling your own email provider triggers all email templates to also be disabled; when you then switch again to your own provider you’ll be able to enable some of the templates through the UI switches, however, those switches are not available to all templates (the reset password being one of them). This is already being tracked to be addressed as the fact that the email template was disabled is not obvious and as such leads to these situations.

Meanwhile, you should be able to workaround this situation by manually updating the templates that have been disabled through the API endpoint. Have in mind that v2 of the Management API does not expose endpoints to update email templates so you’ll need to perform these actions through Management API v1.

After having obtained a Management API v1 access token (see the process to obtain one here) you can perform the following request to address the situation for the reset email template.


PUT https://{tenant}


Authorization: Bearer {mgt_api_v1_access_token}
Content-Type: application/json


	"disabled": false

You can perform similar request for other email templates, just update the template name in the URL (see Management API v1 docs).


Thanks a lot @jmangelo . This was really helpful. Not only was the answer exactly what we needed but also explained the detailed process on how to fix it.

Thanks a lot!


This worked for me!


This worked, thank you for your reply.
However this is not obvious at all. Period. I saw the switches in other mail templates. I saw that this template doesn’t have them. Which let me to the conclusion it’s always enabled. I cannot even tell at any point easily if my reset emails are enabled at all without sending a test! I spent some 5 hours hunting through settings and docu of the portal and than when I found your post another hour trying to understang what a “non global client” is, as management API didn’t give me the token.
This is not a minor bug. Please address it.


This was not considered a minor bug; if the way I answered came across like that then it was my bad. Based on the information I have it it was also already addressed, however, in some situations the damage was already done and if you already had the email templates disabled then the fix would not resolve your case because there’s no way to know if the template was disabled by the bug (which in that case it could be re-enabled or if it was disabled intentionally).