Auth0 Home Blog Docs

Custom email provider: test works, but not password reset



Hello. I’ve followed to use AWS SES as custom SMTP. Upon setup, the “Send Test Email” worked. Upon request password reset, email is not sent. Changing the email provider back to default Auth0, then requesting password reset, an email is sent.
Is there a way to check if I did something wrong on Auth0 side, or AWS side? Or is there anything else to check for? Thank you.


Just to add, it’s not just password reset. Upon new user creation, Email verification works with default auth0, but not with AWS SES. Again, the “Send Test Email” works with SES – we receive the test email.


There was an issue some time ago, where the templates were disabled when you’d disable your own email provider, even if you then re-enabled it again. Could you try the workaround provided here?


Thank you. That resolved the issue.
Side note: according to v1 API, we should be able to GET the email templates. I’m able to GET verify_email, but not reset_email. For reset_email, it says “No Result”. Just ran into this while trying to debug why the referenced answer didn’t work for me – I was doing POST, not PUT. So I tried to debug by GET.