Emails are not being sent when customizing Amazon SES

Problem Statement

We are using SES as our email provider. The configuration test emails are coming through just fine, but when we invite a user to an organization or create a change password ticket, the emails are not being received. We are getting different ticket URLs from the response from Management Client, but no emails. We have tried both our corporate email addresses and also Gmail addresses. What could be the possible issues and how can we get this resolved?

Troubleshooting

Check tenant logs for type: “fn”
Check errors - common error in this case is:

"error": "Email address is not verified. The following identities failed the check in region [AMAZON REGION HERE]: [TARGET EMAIL HERE]"

Check FROM addresses in use in email templates.

Cause

Amazon SES requires that emails used for sending are verified when it is in “sandbox mode”.

When customizing the FROM value for a template (or the default from address), the email used for the from address must be verified in SES.

Solution

You must either verify all of your intended From addresses or move your SES account out of the sandbox mode: