Auth0 Home Blog Docs

Unable to use Domain Connection with First-Party client with explicitly enabling it

deployment
custom-login
database-connections
cli

#1

Some quick context, we are using the auth0-deploy-cli to set up some automation for our Auth0 tenants. The issues I’ve run into is that any time our custom DB connection is updated, it will be disabled for all of our first-party clients unless I enumerate them in the “enabled_clients” property. I will also add that we are using a custom login page, but NOT the Auth0 lock package. It uses the auth0.webauth package.

I tried elevating our DB connection to a domain connection, but I still am unable to use the connection without explicitly enabling it for the client. I’m not sure if I am missing something.

Is there a way to either:

  1. Allow a first-party client to log in using a domain connection without having to explicitly enable it. This is probably what I’d rather do.

OR

  1. When updating the connection via the deploy CLI enable it for all first party clients without having to enumerate every client in the “enabled_clients” field. I could do a “get all clients” call, scrape that, and put it into the deploy CLI yaml, but that seems a little smelly to me.

Thanks!