Auth0 Home Blog Docs

"Connection is disabled" - why is Auth0 not trying the enabled connection?

I’m having a strange issue where we are switching connections to a production connection. We are disabling the connection we had for testing and enabling the new one. However, when we try to log in (using the Resource Owner Password Grant) it gives us the error:

{“error”:“invalid_request”,“error_description”:“connection is disabled (client_id: CLIENTID - connection: OLDCONNECTIONNAME)”}

We’ve even deleted the user from the test database and it’s still giving this error.

It seems like it’s trying the disabled test database and then giving up before trying the connected database.

Would appreciate a quick response on this!

Hi @james.bateson,

Just to confirm, you have disabled the first connection and enabled the second under the app’s “Connections” tab?

Hi. Thanks.

Yes That’s right. I actually managed to figure it out. I needed to set the “Default Directory” in the tenant settings to the new connection (connection-2 in your example). I guess that makes sense but it had me stumped for hours and actually had to delete the original database for the helpful error to be given to me.

1 Like

Glad you figured it out, and thanks for sharing the solution! Setting the default directory is curious to me … I’ve not had to do that before. Sounds like some crossed (virtual) wires. I’m going to check my logs for any “connection is disabled” messages.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.