Issue creating new database connections starting today (1/14/22)


I am having issues with any database connection created today (I have set up database connection successfully in the past, including one yesterday). After creating and setting up the connection settings, including giving it access to multiple applications access, I am getting the following 400 error: The connection is disabled.

I get this error when I “Try Connection” in the database connection settings, when I manually create a user in this db connection, or when I attempt to use the management API to create the user.

Any suggestions would be greatly appreciated (or, if this is an Auth0 bug, a sense of the timeline to resolution).

Thank you,

Hi @john_inspiren,

Welcome to the Auth0 Community!

The The connection is disabled error happens when the Database connection you created has not been enabled for any applications.

Be aware that the Try Connection feature may occasionally cache a previous configuration and result in the scenario you observed.

In this case, please navigate back to your Database connection settings, click on the Applications tab and make sure to toggle on all the applications you prefer.

Once you have done that, you can log into your Database by specifying the connection parameter in the /authorize request.


Please let me know how this goes for you.


Hi @rueben.tiow ,

Thank you for the reply. The database connection was enabled for five different applications (and still is), yet I continue to receive the same error message. I get the connection is disabled error in multiple management API route: when creating new users (POST /api/v2/users) in that database and when trying to use that database as the “realm” when logging in (POST /oauth/token). The Try Connection test is also still failing.

I noticed these issues on Friday and they have persisted through today. I have created and tested a new database connection as well, that similarly has multiple applications toggled on. I am experiencing the same issue.

Do you have any other suggestions? This is a time-sensitive issue for my company and it would be great to get it resolved. Our client needs a separate working database connection to allow for custom password requirements.

Thank you,

Hi @john_inspiren,

Thank you for your response.

To best assist you, could you please clarify how you are creating and testing the database? Is it through the Auth0 Dashboard or the Management API?

Now, note that the realm parameter you use must correspond to the name of the connection on your Tenant.

Additionally, the Try Connection button in your database can sometimes be unreliable for testing. Instead, I strongly recommend calling the /authorize request to your app, or using the Get Started > Try it out button.

Lastly, could you please check if you can register the user on your app via the Universal Login Page?

Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.