Auth0 Home Blog Docs

Auth0 deploy cli with default database connection

database-connections
cli
#1

Hi,

I am using the auth0-deploy-cli to create a full setup on Auth0. We exported everything, including the Username-Password-Authentication database connection. Everything imports correctly. But when trying to add a user I get the following exception:

You have turned the switch to use your own database instead of Auth0 and you have not implemented the “Create” script. Either implement it or make sure you turn off the “Use my own database”.

The switch to use my own database is off. I have no idea why I cannot create users in that connection while creating one manually everything works as expected. I do not see any difference between the manual and automatic creation…

Kind Regards,
Jan

1 Like
#2

Hi there, we’ve got the same issue

#3

If you have been unable to find a solution, I was able to resolve the issue by adding the following into the options section of the database.json within the database-connections configuration.

"enabledDatabaseCustomization": false

#4

Thanks Jared!

Just tried your suggestion and I could add a new user without any problems.

Kind Regards,
Jan

closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.