Domain Level Connection is disabled

Hello,
I have a connection which I have promote to domain level. According to documentation, I expect that all the clients should have access to it now so I removed all the entries from enabled_clients.
The behaviour I did not expect is that the connection seems to be disabled now.
When I test the connection trough play button from auth0, “error”: “invalid_request”, “error_description”: “the connection was disabled” message is displayed.
It is necessary to have something in enabled_clients in order to have the connection enabled?

Hi @cristian.deac,

Yes, that is correct. You can pass the Client ID of the applications that you’d like to enable the connection for. When a new application is created, the connection should be enabled by default.

Hey @stephanie.chamblee, thank you for your response.

The connection will be available for 3rd party clients, that is why it is a domain level connection. 3rd party clients cannot be added in enabled_clients:

“statusCode”:400,“error”:“Bad Request”,“message”:“third party clients are only allowed on domain level connections”

Sorry about that, I missed that this is for third-party applications.

You are correct. enabled_clients only need to be listed for first-party clients when the connection is set to the domain level. The domain connections should be available automatically for third-party apps.

Are you using the Classic Login Experience? If so, you’ll need to include __useTenantInfo: config.isThirdPartyClient in the lock configs.

If that isn’t it, would you mind private messaging me your tenant name so that I can replicate your settings? Thank you!

Also, you’ll have to test the connection from the third-party app. The test button will only test connections enabled for first-party applications.

For example, when I press the play button in connections, I get an error:

But when I log in from a third-party app, I am able to use the connection:

Good catch @stephanie.chamblee. The confusion was created by the “Try” button. I tested the connection from the 3rd party app as suggested and everything look good.
Thank you!

1 Like