Auth0 Home Blog Docs

Cannot add third party client to domain connection

client
connection

#1

I’ve promoted my connection to a domain connection, and the management api shows is_domain_connection as true for the connection. However, when I try to add a 3rd party client, it gives me an error stating

"statusCode":400,"error":"Bad Request","message":"third party clients are only allowed on domain level connections"

I get the same behavior from the management dashboard.

Am I doing something wrong here?


#2

I was able to reproduce this situation and the message can indeed be confusing so I logged an issue internally so that the error content can be improved; thanks for reporting this situation.

Having said that, despite the confusing error the behavior of not enabling a third-party client explicitly is to be expected. The reasoning here is that once you promote a connection to be a domain connection the it will be available to all third-party clients so there’s no need to explicitly enable them individually at the connection level.


How can I elevate my connection to a domain level connection
#3

I am having the same problem.


#4

The original answer was not clear so I provided an update; the error in question is confusing so it should be improved, however, the behavior is expected; see the updated answer.


#5

Well, I am having trouble with consent dialog which is not showing up for 3rd part clients. All I am getting is Something went wrong. Please contact technical support.

Any clue what problem that may be? Thank you.

You can try this link https://fpm.auth0.com/authorize?client_id=77M5h0vArMc7NdsIlsZRYGgg7NJUp6bn&redirect_uri=http://domain.com/callback&response_type=token&scope=openid%20profile%20teams:read%20admin%20queue:read&audience=https://api.friendsplus.me


#6

Thanks for the update @jmangelo.

I went back and looked at the docs some more, and realized that I was missing __useTenantInfo: config.isThirdPartyClient in my hosted login page.

The login page would just spin forever before, not showing any login options, and I attributed that to the third party client not having any connections.


#7

I would suggest raising this as a separate question and adding detailed information (steps) so that it’s possible to reproduce this in another account.


#8