Auth0 Home Blog Docs

Not able to add connection to third party app; even though connection is domain enabled : true


#1

Hey There,

I am trying to get third party Apps to work on Auth0.
I have already created a new third Party App following this guide https://auth0.com/docs/api-auth/dynamic-client-registration and have enabled domain_level_connection on one of my connection.

However, when I go to the Third Party Application and enable that particular connection, I still get an error
“third party clients are only allowed on domain level connections: XXXXXXX”

Any ideas why ?
As a result of this, my Third Party App has no connections enabled and hence the login does not work as well.


#2

ok. I figured it out.
The UX really needs to be worked upon at Auth0.
Basically, domain_level_connections are available for all applications, they cannot be added to the application.

Also, the issue I had was the __useTenantInfo: config.isThirdPartyClient setting on the custom login page was not setup; but, the error was not clearly visible and it felt the error was due to the connection not being able to add on the application.


#3

I’m glad to hear that it all came together @maaz.contractor! You mentioned that the UX needs to be touched on, what do you recommend to improve this? Thanks in advance!


#4

A few things.

  1. improve your documentation of making a connection a Domain level connection.

This curl Request
curl --request PATCH
–url ‘https://YOUR_AUTH0_DOMAIN/api/v2/tenants/settings’
–header ‘authorization: Bearer API2_ACCESS_TOKEN’
–header ‘cache-control: no-cache’
–header ‘content-type: application/json’
–data ‘{ “flags”: { “enable_dynamic_client_registration”: true } }’

That you have here https://auth0.com/docs/api-auth/dynamic-client-registration does not work.
I had a hard time getting this command to work.
I finally got it to work by going to the API Explorer and using the command from there.
The API Explorer has a different curl PATH command syntax; and that worked for me.

Also, the API Explorer is confusing as hell. In the https://auth0.com/docs/api/management/v2#!/Connections/patch_connections_by_id it does not actually say that is_domain_connection: true is an option in the request. Can you please document correctly what all can be done here in the request ?

  1. After that, once my connection was made domain level, I would go to My Third Party App -> connections and see all connections as disabled. Even if I enable that particular connection, I just made domain level, that action will fail and I will get an error called “third party clients are only allowed on domain level connections: XXXXXXX” which does not make sense, or I feel that step #1 did not go through.
    So, Ideally, you guys need to change the App -> Connections settings and just show all connections where is_domain_connection: true as enabled and no option to disable them.

Hope this helps and makes sense.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.