The users don't receive email verification anymore


I tried to fix this problem in email templates. It seems that it works but I don’t receive verification email.

1 Like

Hi @xenia,

I apologize for the delayed response. Are you still running into this issue? If so, can you please provide me with the steps to reproduce, any errors you are receiving (please check the Auth0 logs), and I will try to reproduce. Also, please verify that you have set up an email provider and are not using the Auth0 dev keys.


1 Like

Hi @dan.woda,
Thank you for your reply!
Actually I still have this issue. Some people don’t receive verification email and as a log I have this:

  "date": "2020-06-04T15:10:52.395Z",
  "type": "fn",
  "description": "To:",
  "connection": "Username-Password-Authentication",
  "connection_id": "",
  "client_id": "CRuHQNmG11Aj4e1oX221alQClAkPlI2X",
  "details": {
    "email_type": "verify_email",
    "to": "",
    "error": "Invalid login: 535-5.7.8 Username and Password not accepted. Learn more at\n535 5.7.8 g18sm4410836pgn.47 - gsmtp"
  "log_id": "90020200604151057449000862404835455587204963358717509698",
  "_id": "90020200604151057449000862404835455587204963358717509698",
  "isMobile": false,
  "user_agent": "Other 0.0.0 / Other 0.0.0"

Sometimes it happens also with gmail accounts, when the “connection” is "Username-Password-Authentication”. But sometimes it works. I don’t understand why.

Could you help me, please?

Kind Regards,

1 Like

Would you DM me your tenant name?

It looks like this error is coming from your email service. Can you check those logs?

The last log error is this:

“date”: “2020-06-08T15:41:01.986Z”,
“type”: “fn”,
“description”: “To:”,
“connection”: “Username-Password-Authentication”,
“connection_id”: “”,
“client_id”: “3Wrobd7Scc5lCAipjsz7i9VuIUJIpv2P”,
“details”: {
“email_type”: “reset_email”,
“to”: “”,
“error”: “Invalid login: 535-5.7.8 Username and Password not accepted. Learn more at\n535 5.7.8 Check Gmail through other email platforms - Gmail Help u128sm7514407pfu.148 - gsmtp”
“log_id”: “90020200608154107251000747148978262831850096846102855746”,
“_id”: “90020200608154107251000747148978262831850096846102855746”,
“isMobile”: false,
“user_agent”: “Other 0.0.0 / Other 0.0.0”

I don’t think I was clear, apologies. What I mean is, can you check the logs of your google email service you have set up? The one you would have connected to auth0. It appears to be a google service that is saying you are providing the incorrect username/pw combo.

I believe you need to make changes in your google mail account. In setting turn on Less secure app access.
Hope this solves your problem.


1 Like

Excuse me, how can I check logs of my google email service?

This could be the security issue if you are using correct email and password try to update settings of your gmail account
settings->security find option of Less secure app access and turn it on.

I’m not actually sure, I haven’t used google as an SMTP service.

Thanks for the reply @John.ICM.

Let us know if that works for you.

1 Like

Thanks dan
I was in a kind of same situation days ago and came to the above mentioned solution

1 Like

@John.ICM, @dan.woda Thank you for your answers!
It’s what I have in Google security settings:

It seems that it was already set.

Should I use another SMTP service for better experience?

I have sendgrid set up on my testing tenant and it seems to work without issues. It is one of the default service options.

This doc lists them out:

Sorry For the late reply
Yes turn it off…

1 Like

@John.ICM, i turn it off and received “Critical security alert” and the email verification was not sent. :frowning:
When it is turn on, sometimes the email verification is sent and sometimes not . Honestly, don’t have idea how to fix it.
Do you have other suggestions?

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Link this FAQ to this topic as it talks about the same error with solution.