Not receiving email with SMTP Gmail Service

Last Updated: Dec 3, 2024

Overview

The email is not being received when trying to test the change password email by using SMTP Gmail service as the custom email provider.

The log shows the following error description:

Invalid login: 535-5.7.8 Username and Password not accepted

Applies To

  • SMTP Gmail service

Cause

Some apps must provide a Gmail App Password to connect to the Gmail service, as Google asks for it if it is a non-Google app or a device trying to log in.

Solution

To set the credentials on the Auth0 side, follow these steps:

  1. Go to the Dashboard.
  2. Click on Branding in the left menu.
  3. Click on Email Provider.
  4. Complete the Username and Password using the new credentials.
  5. Click Save.