Problem statement
When I create a new ticket in the support center and click the ‘Affected tenant’ dropdown the tenant I want to choose is not present.
Cause
It’s most likely that the correct subscription is not selected. Some customers have multiple subscriptions and may have production tenants under one and development tenants under another, for example.
Solution
It may be that the tenant you wish to select is under a different subscription. You can change the subscription selected using the dropdown at the top of the page: