Overview
A tenant member was invited to a tenant in a Private Cloud but could not accept the invitation or log in.
Cause
- The invited member’s account is not pre-created in the config tenant.
- The Private Cloud uses a database (username + password) connection, and the invited user needs to reset the password before the first login.
Solution
Say a member with the email “someone@example.com” is to be invited to tenant X.
A. Tenant member in the config tenant with the “User - Edit” role: Pre-create the user.
NOTE: This step is only applicable if doing email/password login. This step does not need to be done if using SSO.
- Log in to the Auth0 dashboard for the Private Cloud.
- Switch to the config tenant.
- Navigate to User Management > Users and create a user with the email “someone@example.com”.
B. Tenant admin in the tenant X: Invite the member to the tenant.
- Log in to the Auth0 dashboard for the Private Cloud.
- Switch to the tenant X.
- Click Invite a Member in the top left dropdown.
- Assign desired permissions and send an invitation.
C. The invited tenant member: Reset the password and log in to the tenant X.
- Go to the Private Cloud’s login page.
- Request a password reset email by clicking the Forgot password? link.
- Find the password reset email, click the link, and set a new password.
- Find the invitation email, click on the invitation link, and log into tenant X using the new password.