Overview
After being added as a tenant member, some members receive communications from sales regarding a trial.
Applies To
- Adding tenant members
- Emails
- Sales Comunications
Cause
If using a username + password Auth0 account to accept an invitation to become a tenant member, the member must have signed up for an account already with Auth0. This is documented here:
- When the invited user clicks the link to accept the invitation, they will be asked to log in with the invited email address. They can then choose whether to log in with a social provider or with their email address and password. If they choose to log in with their email address and password, they must have already created an account with Auth0, or they will need to sign up first and then accept the invitation again.
- Using an OAuth2 social identity provider (e.g., LinkedIn, Microsoft Account, GitHub, or Google) does not require the user to sign up ahead of accepting an invitation.
Signing up for an Auth0 account will start the tenant member on a flow to set up a free trial tenant, this can be skipped however, and the invite accepted after making the account to only link the member to the desired tenant & subscription. But if the tenant member follows the steps prompting them to create a tenant, the member will have a trial tenant subscription created for that member’s account.
Solution
If a newly invited tenant member has set up a trial tenant in error, they can delete the tenant.
The impacted user can check for additional subscriptions tied to their account in the Support Center.
- Once logged into the Support Center, there is a Subscription dropdown on the top navigation bar. Once the Free subscription has been selected using that dropdown, the Tenants button in the navigation bar will show the free tenant(s) they have made in error (this, by default, will have a name like “dev-[random alphanumeric string]” if the tenant member did not modify the name at creation).
- To delete the tenant, have the tenant member switch to the trial tenant by using the dropdown in the top left of the tenant dashboard:
- Then, follow this procedure to delete or reset a tenant.
NOTE: Tenant deletions cannot be undone, so be sure the correct tenant is being deleted before proceeding.