Auth0 Home Blog Docs

Password Reset email not being sent?



I am using the webauth stuff and can log in. However, when I call the “Forgot Password” endpoint and get a HTTP 200 “We’ve just sent you an email to reset your password.” response, the email seems to not be sent. Is there a configuration setting that would be preventing this from working? I was able to do it earlier in the week and it worked.

I am using the default email provider (Auth0).
I saw another message about this that indicated to look at auth0 logs, but not sure where that might be.



I’m having the same issue with the default email provider (Auth0).
The “Logs” page says it has successfully sent out the email, but I’m not getting it.
I tried to send it to different email domains, including, but symptom is the same.


ok - it looks like it took about 15 minutes for the email to arrive in my case. Did they eventually arrive for you?


It took about an hour for me. I ended up using a third party smtp service after wasting several hours in frustration.


The built-in email provider is purely for testing purpose; it is not recommended to be used for production, and isn’t supported as such. If you are facing issues with the email provider, we recommend setting up a custom provider, as outlined in the docs: