Emails not being sent (including with custom SMTP provider)

This was brought up in another thread, but it’s been marked as solved, so I want to bring it up here, because I think there’s a deeper problem.

Basically we rely on passwordless auth through email, but emails aren’t being sent.

We setup an external SMTP provider (MailJet) and the SMTP test email sent by Auth0 went through immediately, but auth codes are not being sent, leading me to believe there’s an issue somewhere else in Auth0. A few hours ago, everything was fine. The only change we’ve made is switching to custom SMTP after the emails stopped working.

Just for reference, here are the Auth0 logs:

Here are the MailJet logs:

So when Auth0 does send emails through MailJet (like the test email which appears in the mailjet logs), it seems to work fine. But the Auth0 logs show auth codes that never make it into MailJet at all.

Since we haven’t changed anything, my instinct is that something is going wrong internally with Auth0?

Just figured I’d make this new thread for visibility because now we’re getting a bunch of users emailing us saying that auth isn’t working.

1 Like

I can confirm we are also experiencing this issue. We do not have a custom SMTP provider.

We’re also having an outage because auth0 passwordless login emails aren’t being sent.

1 Like

On our side, we are experiencing very slow email processing on validation emails. Check if this eventually happens in one hour: for us, it takes 45 minutes to receive the email, even if the job appears to be immediately completed. Initially, we thought it was not working, see here:

We have seen some latency with the built-in provider. The built in provider is for testing purposes only and should not be used in production. Please set up a custom provider to resolve this issue.

@mm-raphael If you are still seeing latency using a custom provider, please send me a DM with your tenant name.

For anyone else who comes across this, @dan.woda helped me figure it out :slightly_smiling_face:

The problem was that Auth0 doesn’t use the “from” email configured in the SMTP provider settings for the Passwordless flows. Instead, it has its own separate default “from” email, which is Since most SMTP providers won’t allow emails from unverified sources (i.e. domains you don’t control, like, the emails don’t go through. So you need to update your “from” email in your SMTP provider settings and your Passwordless email settings for everything to work.

In our case, I had setup passwordless long enough ago, that when I switched us over to a custom SMTP provider, I did not remember that I would have to update the “from” email in multiple places.

1 Like

Thanks for posting an update!

1 Like

Thanks for the help! :smiley:

1 Like