Auth0 Home Blog Docs

Node 8 migration for Auth0 Authorization Extension Rules

@konrad.sopala Can you clarify what you meant by “Only code that runs inside your Auth0 tenants will need to be upgrade”? What do you mean by “Auth0 tenants”?

I changed our Auth0 account to use Node 8 and then changed the auto generated rule to reference us8.webtask instead of us.webtask as stated in the Migration Guide, but received an “Invalid API Key” error. Is this something we need to do before June 19th deadline? If we don’t have any other rules besides the “auth0-authorization-extension” that was generated by Auth0 that uses the “us.webtask”, do we need to do anything for the migration?

Hey there @strianta!

Inside Auth0 tenants we mean basically all the code like extensions, rules, hooks custom DB connections and custom social connections code that you can modify let’s call it using Auth0 dashboard so basically only there. No changes in your client side apps (the code you develop yourself) required.

We have some rules and hooks that appear to not need any migration, but we would like to try it. However we’ve been running into an issue with the auto generated “auth0-authorization-extension” rule returning “Invalid API Key” when switching to Node 8 and updating the “EXTENSION_URL” to “us8.webtask” instead of “us.webtask”.

Two Questions:

  1. Will the auto generate “auth0-authorization-extension” be updated June 19th?
  2. Do you have any suggestions on how to fix that error or can you point us to some documentation? We don’t have a DEV environment so all changes would be affecting PROD.

@konrad.sopala Do you have any suggestions on how to move forward to ensure that we have a smooth transition? Like I mentioned in my last comment we do not have a dev environment to test these changes.

We would really appreciate any help/suggestions that you can provide to ensure that our PROD environments does not get impacted.

Hey there!

Sorry I didn’t see your last message. Let me ask the team responsible for that change what is the best way to proceed and get back to you!

Hi @konrad.sopala! Do you have any updates from the team responsible for that change? With the cut off date only a week away, we would like to try to do everything we can prior to have the smoothest transition possible.

Sorry didn’t get the answer yet. I’ll do my best to move the thing forward today and get you the answer for that! Pinging the team in a moment!

Hi there.
Once you upgrade your Node environment to v8, you should to to the Authorization Extension’s configuration page, rotate the API key and publish the rule again.
Rotating the key will solve the “Invalid API Key” error. Republishing the rule will replace the webtask URL with the new us8 subdomain.

Hi @strianta. Did the above solve your issues?

Hi @nicolas_sabena can you just help me where to find the configuration settings.

Hi @nicolas_sabena. We didn’t get to try until this morning. However I don’t see the ApiKey rotate button on our Authorization Extension’s configuration page. I do see the publish rule button though. Below is what I see. Can you point me to where I can find the rotate API Key button please?

Hi @nicolas_sabena @konrad.sopala,

Any help that you guys can provide about rotating the API key would be greatly appreciated.

Thank you in advance!

Hey @strianta are you on the latest version of the extension? You can check by going to the extensions section, in the “installed” tab.

Hey @nicolas_sabena, we are on Auth0 Authorization 2.3. What are the implications of upgrading to the latest 2.6?

Mostly bug fixes and better usage of Management API v2 endpoints:

@nicolas_sabena I upgraded the auth0-authorization plugin to 2.6, rotated the api key and published a new rule after upgrading to Node 8. Everything seems to be working, but I did notice that the new rule that got published still has “” as the url instead of “”.

Is that expected?

Hmmmm… that’s definitely strange… I tried to reproduce on my side and couldn’t reproduce… I get the us8 URL.
Did you change it manually? Or is the rule running with the old URL?

I just checked the rules again this morning and am still seeing the “” url instead of “”. I did not change it manually, the rule is still running with the old URL.

Will this cause issues?

When you hover over the installed extension (in the Extensions section of the dashboard), does the URL point to the us subdomain, or us8 one?

The rule should be pointing to us8, but the extension should point there as well… I’m surprised that republishing the rule does not update the URL in it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.