Auth0 Home Blog Docs

No verification e-mails sent

verification-email

#1

We are currently experiencing an issue where no verification e-mails are sent out and since we require verification it blocks new users from logging into our application. New users are signed up through the management API (POST /api/v1/users) with the following body:

{
    connection: "Username-Password-Authentication",
    email: "john@doe.com",
    password: "test1234",
    verify_email: true,
    email_verified: false,
    user_metadata: {
      name: "John Doe"
    }
  }

The requests do generate a “Success Signup” record in the log screen. I tried sending verification e-mails manually through the web interface in Auth0 and those don’t show up either. We use SendGrid as e-mail provider and are sending regular transactional e-mails out through their API just fine as we speak. I ran the e-mail provider test here on Auth0 which comes through successfully right away.

I also noticed a considerable delay (10-30 minutes) from making the above request till users are starting to show up in API responses and in the users section of the dashboard.


#2

Just to confirm, could you make sure the Verification Emails are enabled on your tenant? The Status switch (shown here: https://auth0.com/docs/email/custom) should be enabled.

If it is and still no verification emails seem to be sent, they might have been hit by an issue we had some time ago, where the templates were disabled when you’d disable your own email provider (even if you then re-enabled it). You can see the workaround here: https://community.auth0.com/questions/9051/%20password-%20reset-mail-not-being-sent

In your case, the endpoint to request would be:

 PUT https://{tenant}.auth0.com/api/emails/verify_email