No signup on new universal login

I can’t seem to get the new universal login screen to show the signup link on our mobile app. There’s obviously a switch somewhere that I’m missing, but I can’t find it. Some info:

  • The “Disable Signups” toggle in the Username-Password-Authentication connection is OFF.
  • Logging in through our portal shows the signup link properly.
  • If I add “screen_hint=signup” as an extra parameter on the OIDC login, I get “signup is disabled” as an error message.
  • If I enable “Customize Login Page” under Branding->Universal Login-> Login, or if I switch back to the Classic experience, the signup tab shows up.

Hi @chrisb,

Thanks for contacting the Auth0 Community!

I understand that you are encountering issues enabling Sign Up for your Universal Login.

First, could you please go to your Auth0 Dashboard > Applications > YOUR_APP > Connections and check which Database Connections are enabled for that application?

Depending on which Database Connection you have enabled, navigate to each connection and switch off the Disable Signups toggle.

Once that is complete, your application will allow users to sign up.

Please let me know if this resolves your issue.

Thank you.

Thanks Rueben! I had a separate connection enabled for that app that didn’t allow signups.


1 Like

Hi @chrisb,

You’re welcome! I’m happy to hear it works now!

Have a great rest of your day.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.