Missing Enterprise Login Buttons

Dear Auth0 Community,
we have created a new Application that is configured in the exact same way as our existing applications. We also activated those Application in our AZURE AD Enterprise connection
However the Enterprise Login Button is not visible on the Universal Login Screen of the new application, but only on the two existing applications.

Does the way, Universal Login is integrated have an impact on these Links? Or is there anything else I can do to understand the reason of the missing button?

Any ideas? Could this be a licence or plan issue? (like not having enough enterprise connections or something?)

Hi @valentin.sauer1

I would make sure the Azure AD connection is enabled for that application, that’s the most likely cause. If that is not the case, then check to see if the connection parameter is being passed.

How are you testing this? Through the Auth0 Dashboard or via the real application?


1 Like

The Enterprise Login button appears when using the “Try” Button in the Auth0 Dashboard and via all other Apps. It does not appear only via this one real application. However the missing enterprise connection is activated for the application.

As far as I know, we never needed to add specific connection parameters to make Universal Login show Enterprise Login buttons and was not able to find something in the documentation, e.g. New Universal Login Experience
Are there any API params or anything that we have to pass to make the buttons appear?

I am looking for the same answer. We have existing social login buttons and we want to add a button for Azure Enterprise login. The docs show some form fields for a button configuration while in the configuration form for the connection, but those don’t show up for us. Any insights?

Hi @valentin.sauer1

I don’t have any ideas here. I’d suggest creating a new application in Auth0, enable only for the Azure AD connection, and then trying that Client ID in your app code. Then start making the application more like your existing one to track down exactly what is going on.

You should not add a connection parameter. If you do, it will ONLY show that connection.

@dale is the connection enabled for the application? If so, follow the same debugging steps covered here for @valentin.sauer1


Thanks, John. I will follow your recommendation.

Do we need to upgrade our “dev” free tenants to paid tenants to be able to test this functionality out? Or is there another way. Ideally, we don’t test on the prod tenant. Thanks.

Thank @john.gateley . I created a new Application in Auth0 from Scratch, still no buttons at all. Actually I would be happy to show at least ONLY the Azure connection, it is still better then showing only the standard login with the database users. I can’t find a documentation about these connection parameters, do you know where to find them?

@dale ince it is the exact same issue with a Google Connection that does not appear as a link, I don’t expect that it is caused by free tenants. Wouldn’t make sense to offer dev-tenants at all with limited functionality I guess.

Hi y’all,

Enterprise connections are not available in free tenants, see here: Pricing - Auth0

This may be the issue.