Deselecting 'Display connection as a button' doesn't hide Enterprise Connection on Login

As the title states, I am trying to allow users to log into our site using Microsoft Azure AD but I want to hide the Enterprise Connection button at the bottom of the login page. Deselecting ‘Display connection as a button’ doesn’t seem to change anything. Is there a way to keep Microsoft Azure AD enabled while simultaneously hiding the button? Is this a bug or user error?

Hi @jfarrell , welcome to the Auth0 Community,

This is a known issue, please can I recommend giving this feedback item an upvote - Hiding enterprise buttons when logging in with organization.
We should be looking to address this soon, since a recent update has allowed for HRD with Organizations.