Inconsistent logo URL on Login page


A logo on login page is showing up inconsistently - sometimes it shows up correctly, sometimes it does not show up at all.

After digging a bit into a problem, I believe this could be a replication bug on Auth0 side. Here is some context:

  • The first logo URL that I have ever specified on a platform was pointing to an AWS S3 signed URL. That worked for a while.
  • Some time later (in about a day), the said URL has expired and started to return 403 HTTP error (my bad). Naturally, logo stopped showing up on Auth0 side.
  • I have updated the logo to point to a correct location with a URL that does not expire. Here is where the problem started to manifest. Sometimes, when I open the Login page I see the correct logo. But sometimes there is no logo at all.
  • When I inspect the network traffic in my browser, it appears that in cases where Logo fails to load it actually still tried to fetch it from the old, broken URL.

The problem have persisted for at least a week, so I don’t think it will be automatically solved with time and might need to be investigated.

Hi @dmitry.zaicew,

Welcome to the Auth0 Community!

I understand you have experienced issues with your logo showing up on the New Universal Login page.

After checking your tenant settings, I found that you have not yet set a Logo URL for your New Universal Login Customization settings.

To set your logo, please navigate to your Auth0 Dashboard > Branding > Universal Login > Customization Options > Widget > Logo URL:

Please let me know if you have any questions.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.