Auth0 Home Blog Docs

Getting "Something went wrong. Please contact technical support."

auth0
passwordless

#1

When I try to use passwordless login and disable all the other connection types I get “Something went wrong. Please contact technical support.”

If I enable another connection type, the error disappears, but it still doesn’t show passwordless as an option.


#3

Can you provide a relevant code sample (with any private info redacted) so we can see what might be happening? Also if you can provide console web logs that would be helpful


#4

Maybe this will help? From the console:

Uncaught Error: Error: At least one database, enterprise or social connection needs to be available.
    at index.js:496

Is that true though? The dashboard allows me to choose only passwordless, and that’s the only sign-in I want to use for my app. Seems like that would be a reasonable choice?


#5

There still needs to be a user data repository enabled for the client.


#6

What @markd just said - you still need to select a way for them to login/authenticate


#7

I’m confused. If I select Username-Password-Authentication then it’s no longer just passwordless. It prompts the user to supply an email address and a password. Is there a way to use only passwordless authentication?


#8

Based on this screenshot, it looks like passwordless is a source of users.


#9

Hi,
you would have to change the hosted page to “Lock Passwordless” template.
Go to Hosted Pages, enable ‘Customize Login Page’ and choose the ‘Lock Passowrdless’ template under ‘Default Templates’


#10

Possibly helpful additional info re: changes needed to Lock here:


#11

The solution from @jan4 fixed it. Could someone add that to the documentation? I couldn’t find that step anywhere.


#12

The info is in the docs, but (IMO) it is not laid out very well. It is buried in the 14 different scenario sub-documents linked from the page below, and there doesn’t appear to be any explicit mention of “just select the passwordless template” for the hosted login page (I admit I’ve only glanced at a few of the sub-documents). There’s a lot of repetition as well. Maybe there’s a way to refactor the docs to pull common elements out to the main page.


#13

Guys I am having exactly the same issue, but with SPA application. Any idea why?


#15

In more specific, I cant get it working in Angular 4. All works in simple html page, but not in Angular


#16

The strange thing is that passwordless js code even not called. Always going into classic behind.