Auth0 Home Blog Docs

SSO Error in passwordless login

Hi Everyone.

My application is using passwordless login, and everything was ok, but today y started to get this error:
GET https://.../user/ssodata 404
There was an error fetching the SSO data. This could simply mean that there was a problem with the network. But, if a "Origin" error has been logged before this warning, please add "https://....auth0.com" to the "Allowed Web Origins" list in the Auth0 dashboard: https://manage.auth0.com/#/applications/.../settings

And after that the application stops. This is something that at least a few days ago was not happening.

Any ideas?

Hi,
just a few questions to isolate the issue origin a bit more:

  • which Passwordless method are you using? (SMS, Email Link, Email Code)
  • which SDK (or tech stack) are you using on the client side to make the authorization request? auth0-js?
  • are you using the Auth0-hosted classic login page with the Passwordless template?
  • is the tenant domain added as Allowed Web Origins in the application settings as mentioned in the error message?

Hi!

  • Email code
  • Authjs 9.10
  • Yes
  • I’ve tried that, and didn’t work

Thanks for your reply.

When does this error occur? When Auth0 redirects back to the app after the user has entered the code?
Can you try with an incognito browser, or clear all cookies.
Are there any other JS errors in the dev console?

Actually, it never loads the login page, i get that error and then the flow stops completely.

I tried incognito, and a couple of browsers, same thing every time.

I managed force the login to get a token, once I’ve done everything runs smoothly. When I clear cookies+cache, or move to another browser, Im stuck again with the error.

I don’t see anything in the logs (both in my app, and the auth0 console logs)

Maybe you can take one of the Quickstart projects from your application quickstart tab (Auth0 Dashboard), run it locally, see if that works (with the same clientID). This way you know whether it’s an issue with the Auth0 application configuration (in the Dashboard > Application Settings) or the way it’s called from your client application.

I’ve seen this error message before in the forum. Maybe some of these are helpful:

1 Like