Error While Enrolling New Device with Auth0 Guardian App

Problem statement

A Dashboard user/tenant member has a new device and wants to enroll for MFA with the Auth0 Guardian App. When following the steps to enroll the new device, they receive the following error:

"Error! Error while enrolling device. Please try again."

Steps to reproduce

The user completed the following steps:

  1. Removed the MFA account from the Auth0 Guardian App of the old device.
  2. Set up a new MFA account on the Auth0 Guardian App on the new device. When the app opens on the new device, it asks the user to scan a QR code from Auth0.
  3. The user logs into Auth0 using a recovery code (received when they first set up MFA).
  4. Clicked the user name in the top right corner of the Dashboard and “Your Profile” to access the Account Settings.
  5. Scrolled down to the “Auth0 Guardian” item, which was showing as a “Not enrolled”, and clicked the “+ Add” button. Then, an error message appeared in the screen’s top right-hand corner:

"Error! Error while enrolling device. Please try again."

Cause

A new window needs to open to continue the MFA enrollment. The browser may be blocking the required pop-up for setting a new MFA account on the Auth0 Guardian app.

Solution

Enable pop-ups in the browser configuration, or use a different browser.