Email Template for Passwordless Connection Not Updating

Overview

This article explains why end users using a passwordless connection may still receive emails that use the default template after attempting to customize the email template.

Applies To

  • Branding
  • Email Templates
  • Passwordless Connection

Cause

The default template may be sent when any of the following prerequisites have not been met:

  • The Auth0 built-in email provider is still in use
  • The from property in the template has not been changed to something without “Auth0” in the domain of the email

Solution

Ensure the following prerequisites are in place to use custom templates with Passwordless Authentication:

  • Ensure a third-party email provider has been configured to send emails in the environment
  • Change the from property in the email template
    • If the from property within the template is set, it overrides the setting at the Email provider level.
    • If that value contains “Auth0” in the domain, Auth0 will send the default email template

See Passwordless Authentication with Email for more information.