Custom Text in Universal Login Not Reflected in Login Form

Problem statement

Setting custom text as a placeholder for username in the login form has no effect in the login box for the application. The change is made in the setting shown in the image below Branding → Universal Login → Advanced Options → Custom Text → Username placeholder.

Symptoms

This can be seen when testing the login box for example using the “Try” button in a database connection such as “Username-password-authentication”.

Steps to reproduce

In the tenant Dashboard.

  • Go to the customizations screen by selecting Branding → Universal Login → Advanced Options → Custom Text → Username Placeholder.
  • Introduce some text to see the changes reflected in the preview picture to the right.

    Also, when testing the login box using the “Try” button in a database connection, it can be seen the username field does not appear.

Cause

The reason for this behavior was the prompt used to present the login box. The prompt used initially was ‘login’.


The authentication method selected under Authentication → Authentication Profile was the Identifier First option.
image
When using the Identifier First option, the prompt to be used under the Branding section should be "login_id ", and the placeholder should be the "emailPlaceHolder " field as shown in the screenshot below.

Solution

The solution is to change the placeholder named "emailPlaceHolder " to the desired custom text. This change can then be seen in the login box.