Config Tenant Password Reset Emails Not Received (Private Cloud Environments)

Overview

This article will address the following issues that newly added admins of a private cloud instance may experience:

  • Cannot access a specific set of tenants in a private cloud environment;
  • Password reset emails are not being sent.

Applies To

  • Private Cloud
  • Multiple Environments
  • New User Added in Config Tenant

Cause

This is most likely happening because there are user(s) in the config tenant of one private cloud environment but not the other. Most of the time, environments will take the naming of {environment-name} and {environment-name}-dev. They might be a user of the config tenant in the main environment but not a user of the config tenant in the dev environment.

NOTE: The naming scheme of a private cloud environment can vary, so please check with an admin of these instances to confirm the environment details.

Solution

The user(s) needs to be added to the config tenant of the other private cloud environment(s) as well, so they can access the tenants in that environment. An admin user with role of ‘Editor - Users’ in the other environment can do this.