Can't set the default audience for a tenant

It is explained that the default audience in tenant settings should be an API identifier. An API identifier can be a string like “my-cool-api” but the default audience only accepts a string in the format of a uri. So if I wanted the default audience to be “my-cool-api” I would see the error ““Default Audience” must be a valid uri”.

I am confused by this inconsistency. Could someone shed some light on this?

Hi there @ryan-cahill welcome to the community!

I am seeing the same behavior you are - It looks like it’s only validated on the client side so using the management API to set a non-uri default_audience will work.

curl -H "Authorization: Bearer <token>" -X PATCH  -H "Content-Type: application/json" -d '{"default_audience":"<the audience>"}' https://YOUR_DOMAIN.auth0.com/api/v2/tenants/settings
 

Hope this helps!

Hey @tyf thanks for the suggestion. Instead, I already found similar issues that have been open since 2020 and created a new API with a random URL.

Can your team please fix this issue? I don’t need help with this anymore, but this is an incredibly confusing UX.

1 Like

Thanks for the follow up! It looks like this is in the backlog to be addressed - Sorry for the confusion!