Bug? Cannot Set Tenant Default Audience (any more)

I have an existing Auth0 integration which has been working fine. It has an API with an identifier like my-api (notice, it is not a uri).

The Tenant Default Audience is my-api. This has been working for well over a year.

Today we tried to setup a new tenant. We created an api with the identifier my-other-api. I then tried to set the Tenant Default Audience to my-other-api. It threw an error saying the default audience must be a valid uri. Odd. So I tried setting the default audience to the url that the API will live at. It threw an error that it was not an identifier.

I went back to my original tenant, and tried to re-save the default audience as my-api, but it threw an error that it must be a valid uri. So it failed to save, but it was already set to my-api! So it can clearly be set to that value, and it clearly works when it is set to that value, but there is no way to set it because it throws an error when I try to save any value in that field.

What is going on? Is this a novel bug in Auth0?

1 Like

Hello! Welcome back.

We sent this question to our Engineering team because we couldn’t find more information regarding this behaviour. We will keep you updated.

Thank you.

2 Likes

Hello again @fildred13,

This is an issue that we identified and we are going to work on it. We will keep you updated when we get news about this problem.

Thank you!

1 Like