Auth0 Home Blog Docs

We're sorry, something went wrong


#1

I’m trying to setup Passwordless Auth using email/SMS. Everything is looks good, the Lock widget also displayed fine in both cases-SMS and Email passwordless authentication.

But, while I do enter the code I’ve received in the email or SMS, I get following message.

“We’re sorry, something went wrong”

I’ve checked console of Firebug, and there’s an empty response with 200 status code. I’m using trial account is this gonna work with it?


#2

Are you using the Universal Login Page? Can you share your lock config? Can you inspect the response and paste the response body here?


#3

Following is the only stuff I’m using:

Login


#4

Here’s the code:

<script src="https://cdn.auth0.com/js/lock/11.6.1/lock.min.js"></script>
<script type="text/javascript">
  function login() {
    var lock = new Auth0LockPasswordless('ntTtjBuBDXgId1dbHN8grd0elrfIMk_e', 'sajalsoni.auth0.com', {
        allowedConnections: ['sms'],             // Should match the SMS connection name  
        auth: {
          redirectUrl: 'http://oauth0.test/',
          responseType: 'code'
        }
      });
    lock.show();
  };
</script>
<a href="javascript:login()">Login</a>

#5

Do you think it could be the problem due to the fact that I’ve not set anything yet in the “Allowed Web Origins” under the application settings?

Atm, I’m testing the app using vhost in my local development environment, thus I don’t have any valid domain name yet. The “Allowed Web Origins” is not allowing me to set “http://localhost” or my local name based vhost URL “http://test.oauth”.


#6

can you inspect the error and see what error are you getting? do you see any error in your tenant logs?


#7

No there’s no error, it’s 200 response but empty! Btn, how to check tenant logs?


#8

You can see logs here: http://manage.auth0.com/#/logs