webAuth.authorize() prompt=login option doesn't work with custom social connection

Library version "react-native-auth0": "^2.1.0"

When calling webAuth.authorize() and setting prompt=login, it works with supported social connections including Google, Facebook, and Apple sign in, the browser pops up correctly and doesn’t automatically log in when the function is triggered. However, it doesn’t work with custom social connections, in my case, Twitch.

Hi @michael.chen - thanks for posting on community. I am just adding my respond in support center here also for visibility :slight_smile:

Upon asking internally, it sounds like not all Identity Providers(IdP’s, i.e. Twitch) support the prompt parameter. So, you will need to look at upstream_params (https://auth0.com/docs/connections/pass-parameters-to-idps). This allows you to send something to auth0 (eg: prompt=foo) and then auth0 will send that to the IdP (in the same parameter or a different one).

Let us know if that works for you!

1 Like