User Receiving "Error getting the bot detection challenge, please contact the system administrator”

Problem statement

This article explains why the following error message occurs when a user attempts to log in, and a captcha is expected to display instead:

  • Error getting the bot detection challenge. Please contact the system administrator.

This error sometimes also appears even if the login attempt is successful and the user is redirected to the application.

Applies To

  • Bot Detection Challenge

Cause

The error originates from the Auth0js script.

This error occurs due to one or more of the following reasons:

  • An expired or invalid state exists in the login path.
  • The user clicks the Back button during the login flow.
  • Cookies are blocked by the browser, which prevents the login flow from functioning correctly.

In system logs, events related to this issue can include the following description:

You may have pressed the back button, refreshed during login, opened too many login dialogs, or there is some issue with cookies, since we couldn’t find your session. Try logging in again from the application and if the problem persists please contact the administrator.

To find all appearances of similar log events, use the following query in the Tenant’s Dashboard:

Solution

To prevent this error, configure a default login URI. This configuration ensures the user is redirected to the application’s initial login endpoint during scenarios that trigger the error.

The default login URI can be set at either the application or the tenant level:

  • Application Level: Configure the default login URI in the application settings section of the Dashboard.
  • Tenant Level: For instructions on configuring the default login URI in the tenant settings.

Refer to the Configure Default Login Routes document for detailed instructions.