User Receiving "Error getting the bot detection challenge, please contact the system administrator”

Problem statement

In some scenarios, instead of displaying the captcha, the user sees the following error:

Error getting the bot detection challenge. Please contact the system administrator.

Symptoms

The user sees the error below when logging in. The error sometimes appeared with a successful login (redirect to app).

Error getting the bot detection challenge. Please contact the system administrator.

Cause

The error is coming from the Auth0js script.

  • In the Logs, these will appear as follows:

You may have pressed the back button, refreshed during login, opened too many login dialogs, or there is some issue with cookies, since we couldn't find your session. Try logging in again from the application and if the problem persists please contact the administrator.

type:f AND description:"You may have pressed the back button, refreshed during login, opened too many login dialogs, or there is some issue with cookies, since we couldn't find your session. Try logging in again from the application and if the problem persists please contact the administrator."

This error is generated due to one of the following reasons:

  • Expired or invalid state in the login path.
  • The user clicks on the back button while doing the flow.
  • Cookies are somehow blocked by the browser (which would prevent the whole flow from working).

Solution

Set up a default login URI to prevent the error. It can be set at the application level in the dashboard or at the tenant level. Configuring this URL will ensure that the user is redirected to the application login’s initial endpoint during these scenarios.

Refer to the Configure Default Login Routes document to configure it within the tenant settings.