Auth Challenge from Bot Detection Not Properly Visible

Overview

This article explains why an end user is unable to see the Auth Challenge on the Authentication Page. As a result, they cannot proceed with Authentication and are stuck on the first login page.

Applies To

  • Bot Detection
  • Auth Challenge
  • Permissions
  • Javascript

Cause

It is required to have Javascript working for the Authentication flow for the captcha to work normally.

If the Javascript permission is not given, the Auth Challenge will not be displayed and will not work. This is an expected behavior.

If the end user is just prompted to click the Auth Challenge and gets an error, it could be that they are having some network issues, blocking some other permissions like Images, or anything else that would make the system consider them a Bot.

Solution

The end users need to make sure that they have the Javascript permission enabled for the Auth0 Authentication page to be able to proceed through the Auth Challenge Bot Detection.

For the Authentication to work properly, it is recommended for the end users to not block any cookies, IPs or permissions from the Auth0 page. If they do so, there might be issues with these specific end users that cannot be seen at other users or when testing normal authentication flows.

If the intention is to include end users that have the Javascript permissions disabled on their browser, it would be best to change to a Simple CAPTCHA.