User Does Not Appear in the Auth0 Dashboard UI, but Get an Error of "The user already exists" When Creating the User

Problem statement

A user does not appear in the Auth0 Dashboard UI. The user is not shown in the GET /api/v2/users search. However, creating a user using POST /api/v2/users returns a 409 status code and the error The user already exists. This issue is occurring on multiple users.

Cause

User search depends on a few components to propagate user change events (i.e., create, update, delete) from our main DB to our user search index. It is possible that occasionally, a change event is lost due to an intermittent issue with one of the components involved.

Solution

When encountering this issue, contact support to request a re-indexing of the tenant users in the search index.