Unable to use Internationalisation with auth0-angular

I had followed these steps
first of all i had selected languages from tenant dashboard.
than in my login function i had added
this.authService.loginWithRedirect({ authorizationParams: { screen_hint:“login”,ui_locales: ‘hi’ ,language: ‘hi’}} );

my login uri was like this
https://dev-v70f4pj5isuzog5z.us.auth0.com/login?state=hKFo2SAzb2ZzZVZpN1FHUkNrZ2dDZDU0WGFaT0dhM0syUDBDcKFupWxvZ2luo3RpZNkgSEVwYkdJeGlOVUgtOS1rVk5qdGVIdkhBbVhDOUhpTjWjY2lk2SBQVVBvQkVkSUkwbmxlR3hCZUFtcEJkbEplNGhjT0NRZg&client=PUPoBEdII0nleGxBeAmpBdlJe4hcOCQf&protocol=oauth2&scope=openid%20profile%20email&redirect_uri=http%3A%2F%2Flocalhost%3A4500&screen_hint=login&ui_locales=hi&response_type=code&response_mode=query&nonce=SzVqcXl1RlpjYkNYNDNXSGJDMEk4MV9jSUlTRlNwV1VONk5GOGRKWFl1ZQ%3D%3D&code_challenge=aCenWz2T1OFEvCyiYg_S1f7Vp9laRJ5lDfF1VidEVdg&code_challenge_method=S256&auth0Client=eyJuYW1lIjoiQGF1dGgwL2F1dGgwLWFuZ3VsYXIiLCJ2ZXJzaW9uIjoiMi4yLjIiLCJlbnYiOnsiYW5ndWxhci9jb3JlIjoiMTYuMi4xMiJ9fQ%3D%3D

what should i do next.

Hi @mustafaabdeali284,

Welcome to the Auth0 Community!

I have looked at your tenant settings and see that you have configured to use the Classic Universal Login experience.

When using the Classic Universal Login experience, localization is done through the login widget using the language configuration option.

Please refer to the following documentation:

Let me know if you have any questions.

Thanks,
Rueben

Thank you,everything resolved . I have one more Question can I pass language dynamically to authguard provided auth0-angular package. i am having an api which takes current website uri and provides language. I want to pass it in authguard ui_locales.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.