Internationalization of login screen issue

Hi,

I have a problem with setting language of login page. I am using new universal login page. I have set polish language in tenant settings as available (and default). During authorize request this value is sent in query string as ui_locales=pl. The problem is, that the login screen is still displayed in English.

My code to configure this is rather simple:

<button (click)="auth.loginWithRedirect({ui_locales: 'pl'})">Log in</button>

I have also tried with ui_locales set to po since this is the code shown in this site (pl is used in tenant settings). It didn’t work anyways.

Where is my mistake?

Thanks,
Kamil

  • Which SDK this is regarding: @auth0/auth0-angular
  • SDK Version: 1.3.1
  • Platform Version: Angular 11

I am receiving such response from browsers:

Edge: accept-language: en-GB,en;q=0.9,en-US;q=0.8,pl;q=0.7
Chrome: accept-language: pl-PL,pl;q=0.9,en-US;q=0.8,en;q=0.7

Czesc Kamil! Is it displayed in Polish on either of the browsers?

Cześć! :slight_smile:

No, it is not. It is displayed in English on both of them. Can it be because my Windows distribution has English language set?

I’m not sure experienced with Angular but let me dive quickly in our docs and I will get back to you shortly when I find something!

1 Like

It seems that it should be working. straight away with adjusting the language in tenant settings:

https://auth0.com/docs/universal-login/universal-login-internationalization#setting-the-tenant-supported-languages

In the General tab on your Tenant Settings you will be able to select the languages you would like to allow.

I have it configured like that:

What if you tick off English and German? I’m wondering if it’s not messing with your Angular code snippet

I had it configured as only Polish earlier. No difference, unfortunately.

Ok then it’s the angular part. Give me a few more minutes

1 Like

I went through all the docs on customising language of New UL and it seems that you can’t do anything more on your end. I’m gonna bring this to the attention of teams responsible for Universal Login and once I have any info from them I’ll let you know!

Thank you very much for that. I will wait for them to answer, then.

1 Like

Thank you a lot and sorry for the inconvenience!

That is really weird but I asked the main maintainer of our angular sdk to test this and they got it working with ui_locales: ‘pl’

In order to double-check this, I have once again followed the setup guide and still received an English login page.

I assume that this maintainer has a browser and OS set to English language, right?

Is there a possiblity to share this codebase for me to launch it on my local PC?

Hey there Kamil!

Sorry for the delay in response.

Here are the steps how we tested this:

loginWithRedirect() {
  this.auth.loginWithRedirect({
    ui_locales: 'pl'
  });
}

Shows up in Polish when using the New UL. You do have to enable pl locale in tenant settings.