Last Updated: Jul 31, 2024
Overview
After setting up Sendgrid as the SMTP provider, passwordless emails are no longer being received. There are “Failed Notification” (type: fn) entries in the tenant logs with the following error description:
The from address does not match a verified Sender Identity. Mail cannot be sent until this error is resolved. Visit Sender Identity | SendGrid Docs | Twilio to see the Sender Identity requirements
Applies To
- SMTP Provider
- Sendgrid
Cause
In the Email passwordless connection settings, the ‘From’ email was set to <root@auth0.com>.
Solution
Navigate to Dashboard > Authentication > Passwordless , click on Email and add an email address that is registered as a Sender Identity with Sendgrid in the ‘From’ field.