Tenants and Subscriptions

Last Updated: Dec 2, 2024

Overview

As indicated in the documentation Set Up Multiple Environments, it is best practice to set separate non-production and production environments/tenants, leading to the use of multiple tenants for a single project. This requires the use of the same features through the tenants and, consequently, the same subscription entitlements.

Tenants with different subscription types and entitlements might present different limitations when switching between them and trying to do things like adding a custom domain if they belong to different subscriptions. E.g., the Dashboard shows a warning saying:

This feature is not available for free plans. To configure a custom domain, please upgrade your account to any paid plan.

This raises the question of whether a single subscription applies to all these tenants or tenant-wise.

Applies To

  • Subscriptions

Cause

For Self-Service accounts, subscription versions of the current plans below 8.0.0, Developer, Developer Pro, Gold, etc., are applied tenant-wise, with one tenant per subscription.

Solution

For Self-Service accounts (subscriptions managed from the Dashboard), there are two possible scenarios:

  1. For legacy B2B and B2C plans (versions below 8.0) or other legacy plans, like Developer, Developer Pro, Gold, etc., every tenant has its own subscription -hence, separate billing details, quotas, etc. Consequently, the subscription must be managed separately for each tenant from the Dashboard > Settings > Subscription tab for legacy subscription versions. This type of plan is also called Tenant-Based.

  2. For self-service Team-Based accounts (version 8 onwards), multiple tenants can be linked under the same team/subscription depending on the chosen plan. The plan descriptions found on the Auth0 Pricing page refer to team-based plans.
    A team member with the owner’s role can self-manage this process from the team dashboard by linking existing tenants or creating new ones under the team.

Instructions on how to manage each subscription type can be found in the Manage Subscriptions documentation.

NOTE: The instructions found in Link Multiple Tenants to a Single Subscription apply only to Enterprise subscriptions.