Auth0 Home Blog Docs

Something went wrong. Please contact technical support

I setup my mobile app for universal authentication (React Native) and when the hosted page pops up in a web view on iOS I get “Something went wrong. Please contact technical support.”

I followed the steps in the quickstart and am not sure what’s going on, any help would be appreciated.

Hello, @trainr. Thanks for reaching out and welcome to our community.

Usually, the error page explains what is the problem. Sometimes is as clear as the following one, sometimes the error is a little bit more hidden.

On the example above, you can see that the page is stating that http://localhost:3000/callback is not in the list of allowed callback URLs. In that case, I would have to evaluate what I have done wrong (perhaps I forgot to add this URL to the Auth0 Application page, or perhaps I mistakenly configured the Auth0 library in my app).

If the page is not that clear, it will probably add some info on the Technical Details section on the bottom.

As you can see on the page above, after clicking on the See details for this error link (now called Hide …), I will get some info about the error.

Please, can you check your error page and see if you find valuable info there? If not, let me know and I will help you investigate.

Hi @bruno.krebs - It’s a mobile site (safari) and there is no information other than “Something went wrong. Please contact technical support.”

There is no technical details link or anything on the page so I’m not quite sure how to debug this.

Is this is repo that you can share? Have you checked the Logs in your Auth0 tenant?

Hi @bruno.krebs,

This is a private repo, but in short all I’m doing is the basic setup for react native and calling:

const auth0 = new Auth0({ domain: Config.AUTH0_CLIENT_DOMAIN, clientId: Config.AUTH0_CLIENT_ID })
auth0.webAuth
.authorize({ scope: Config.AUTH0_SCOPE, audience: Config.AUTH0_AUDIENCE })
.then(credentials => {
// Do stuff
})
.catch(error => console.log(error))

One interesting note is that I’m using passwordless. If I disable the passwordless (email) connection for this app and instead use the default database connection that was pre-configured at sign-up, then the page loads and I can put in an email/password. It’s only failing when I try passwordless.

I checked the Logs under Advanced Features and there was nothing there.

Hmm, interesting. I will check with my colleagues and see if they manage to help you.

Hi @bruno.krebs - Any word from the customer support team? I can’t get the passwordless view to load. I even tried deleting the native app and creating a new one. Perhaps something is wrong with the account?

Hi @trainr ,
I think you need to add the URL " http://localhost:3000/callback " (OR the IP of the machine that is running react eg: http://192.168.1.108:3000/callback
) in the allowed-callback-urls section , in Auth0 -dashboard .( in application -> settings)

Hey there @trainr!

Let me know if you had a chance to try what @adb suggested. I just started following this thread so if that won’t work I’ll discuss it with one of our developer support engineers!

Hi @adb - This is a react native project. The instructions for getting up and running say to set different callbacks (which I’ve set). Essentially:

{PRODUCT_BUNDLE_IDENTIFIER}://mydomain.auth0.com/ios/{PRODUCT_BUNDLE_IDENTIFIER}/callback
{PRODUCT_BUNDLE_IDENTIFIER}://mydomain.auth0.com/ios/{PRODUCT_BUNDLE_IDENTIFIER}/callback

I think the localhost callback is for SPAs/Regular Web Apps.

@konrad.sopala - Yes would really appreciate some help here to debug this, I’m out of avenues here and will need to go look for another solution if I can’t get past this. Much appreciated!

1 Like

That is true.

Any chance you can share the callback-URL you have configured on Auth0-dashboard ( chances are that might be incorrect ).

Hey there @trainr!

Sure I already reached out to the team. I will let you know once we have the solution or need some more info from you!

I just read the whole thread. From your description it seems like there is a problem with passwordless configuration as you’ve stated that you followed all the steps thoroughly in react native quickstart. Are you sure that you’ve followed also all the steps in the right way for passwordless?

Can I also ask you to send me the screenshots of the whole flow so I can track at which stage do you actually get that error?

Ok figured it out. For passwordless to work I had to do this:

2. Configure your login page

Next, configure your login page. Head over to the Hosted Pages section of your Dashboard. At the top of your the code editor, click the menu entitled Default Templates and pick Lock (Passwordless) from the list.

Before this step I had to click customize, then in the dropdown i selected the Lock (Passwordless). Also had to click save. Then the page loaded.

The instructions are broken for iOS or Android, but not one for React Native (which requires you to do some steps from both sections). I’d advise putting together a section for passwordless setup with React Native to make it easy, that wasn’t too hard to miss and with the mobile safari there was no way to debug this and there weren’t any logs in the web admin panel.

Anyways, it looks like I’m set now, thanks for pointing me to that area of docs @konrad.sopala!

Perfect glad you made it! I’ll make sure to relay that feedback to appropriate team!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.