Auth0 Home Blog Docs

Failed Exchange (feacft / Unauthroized) troubleshooting

react-native
react-native-auth0

#1

HI,

I have a React native app that is currently using the React-native_auth0 1.2.2. I reviewed the startup guide on Auth0 step-by-step and everything seems to work until it tries to get the token. I have set debug statements in the XCode url call back and the schema looks exactly the way it was set in the plist. I am using the Facebook social connection. The login appears in the app in the webview fine. I can successfully log into facebook and somehow after the callback occurs I get this failure: Unauthorized. I don’t where to start troubleshooting this. Any poinrters or steps for me to cross check? Facebook setting have the corect bundle. The bundle id is confirmed in the plist. I can run the test login in facebook in the connection screen fine. The log indicates that I successfully logged into facebook. The URL interact seems fine in the React native app. Are there some pro tips here? Thanks! S


#2

SOLVED. Make sure the Application Type is set to “Native”. Cross check Client IDs too. I have seen this in the past where the wrong client ID from a sample project, etc… made its way into the current project. So, solved.