Sign in with apple for react-native not working. Invalid redirect_uri

I cannot get the sign in with apple work for react-native. I don’t know which guide I should be following if I try to get it to work in browser among other social logins.

The response I get when I try the test is: invalid redirect_uri.

I get it working when I leave it blank and use auth0 test keys. This is the setup for my development version of the app, and it seems to be working fine. But then I switch to my production tenant, and try to do it with real keys, it just doesn’t work.

Could it be that my development version is somehow messing up my production one, because they share some same attributes? Like the bundle identifier is obviously the same (client ID). Also Team ID is the same. Which format should the Client Secret Signing Key to be put there? I just copy pasted it from the .p8 file I got from apple, and when I save the configuration I get no errors.

Is there a video somewhere that would go through the necessary steps? A documentary for react-native would also help. Now I just followed the links below the fields, and they do not give me enough details for making it work.

The instructions on this page:

Are out of sync with the actual form that we are supposed to use to enable the sign in with apple.

For example, the article talks about creating an App ID. Cool, but there is no App ID required in the actual form that we use. So what do I do with it?

What should I put to the return callback url when configuring the service id for apple sign in? Since the return callback is not an url, but it will go back to the app itself, so I can’t put any url there. And apple does not allow me to leave it blank.

Finally got it working. Don’t know exactly what was wrong. I deleted all apple developer settings (service ids etc…) and started over again from scratch. Then I set the callback url just like this: https://MY_AUTH0_DOMAN_NAME/login/callback. And after all this it just started working

1 Like

Perfect! Glad you have it working and thanks for sharing with the rest of community!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.