Auth0 Home Blog Docs

Unsure what redirect_uri to use with 1.6.0

I upgraded from 1.5.0 to 1.6.0 because with 1.5.0 I was no longer being redirected to the universal login screen. With 1.6.0, on iOS, after clicking “continue” when it says my app “want to use auth0 to sign in”, the app opens a screen that says “Oops! something went wrong. Callback URL mismatch. The provided redirect_uri is not in the list of allowed callback URLs”. So far, I have not provided a value for redirect_uri in my call to auth0.webAuth.authorize() because in the quickstart instructions it doesn’t, and I’ve never had trouble with that before. I’ve added the iOS callback URL in my Application Settings as indicated in the Quickstart. I’ve tried adding that same URL ( {YOUR_BUNDLE_IDENTIFIER}://${YOUR_AUTH0_DOMAIN}/ios/{YOUR_BUNDLE_IDENTIFIER}/callback ) as the value for redirect_uri in my auth0.webAuth.authorize() method, but then it redirects to a screen that says “Safari cannot open the page because it could not connect to the server”.

Does anyone know how to approach this?

In the URL entered into your Auth0 app’s callback URL, you need to replace those placeholders with the values they represent.

So instead of entering this in Auth0 app settings:
{YOUR_BUNDLE_IDENTIFIER}://${YOUR_AUTH0_DOMAIN}/ios/{YOUR_BUNDLE_IDENTIFIER}/callback

You should enter something like this:
org.reactjs.native.example.MyApp://MyAccount.auth0.com/ios/org.reactjs.native.example.MyApp/callback

You can find the correct value for ${YOUR_AUTH0_DOMAIN} in the Domain field in your Auth0 app’s Settings page.

I am not exactly sure where to get the value for {YOUR_BUNDLE_IDENTIFIER} yet as I am just getting started with React Native. If you created your app with ‘react-native init MyApp’ then I suspect it might be org.reactjs.native.example.MyApp (obviously replacing ‘MyApp’ with whatever name you specified.

Please let me know if this helps.