Getting 'The redirect_uri parameter is not valid: "{YOUR_APP_CALLBACK_URL}"

I’m seeing “The redirect_uri parameter is not valid: “{YOUR_APP_CALLBACK_URL}” If url looks fine, check that you are not including non printable chars” in my logs. NOt sure where I’m supposed to configure this?

Hello @dbinetti

Could you provide what your redirect_uri appears as? Which sdk are you using? Are you using the universal login page (new or class) or Auth0js?

redirect_uri : The URL to which Auth0 will redirect the browser after authorization has been granted by the user.

Thanks @karen1 I don’t know what you mean by “what your redirect_uri” appears as. I’m using direct calls to the endpoints (using the python requests library).

The error type is “Failed Silent Auth”. Does this help clarify the source of the error?

To be clear, I am only seeing this in the logs. haven’t experienced the error myself so I can’t even tell if it’s a legit problem.

Oh, and using New Universal.

I believe failed silent auth means your Auth0 session has expired (or for some other reason a failure to validate your Auth0 session), which would force the user to authenticate.

Does the error show the literal string {YOUR_APP_CALLBACK_URL} or is it showing an actual redirect URI?

There should be a redirect_uri parameter in your call to /authorize, and that redirect URI needs to configured as a valid callback URL in the associated app/client. e.g,