Setting Domain in Create Enterprise Connection [Auth0 Management API]

I was trying to create Google Apps Enterprise connections using the Auth0 Create Connection API [Auth0 Management API v2]

However I was unable to set the Google Workspace Domain ( as I couldn’t find the exact request body attribute that needs to be passed for it.

I would really appreciate your help. Thanks.

Hi @shreyas.ezhava,

Welcome to the Auth0 Community!

To set the domain for the Google Workspace Enterprise connection, you’ll need to pass the domain and tenant_domain properties to the requesting body.

Please try the following:

  "options": {
    "email": true,
    "scope": [
    "profile": true,
    "client_id": "CLIENT_ID_HERE",
    "ext_groups": false,
    "ext_is_admin": false,
    "client_secret": "CLIENT_SECRET_HERE",
    "tenant_domain": "GOOGLE_WORKSPACE_DOMAIN_HERE",
    "api_enable_users": true,
    "ext_agreed_terms": false,
    "ext_is_suspended": false,
    "handle_login_from_social": true
  "strategy": "google-apps",
  "is_domain_connection": false,
  "show_as_button": false,
  "enabled_clients": [

Once this is complete, you will be able to create the Google Workspace Enterprise connection with the necessary settings. For assurance, you could verify the settings by going to your Dashboard.

Please let me know if you have any further questions. I’d be happy to help!

Thank you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.