Auth0 and google workspace access_denied

I have configured a test app in google workspace and set it up at auth0 as an enterprise connection, when testing it, it was successful to the permissions screen, ( wants to access your google account).
After hit Allow in the permission screen, I get the following error:
{“error”:“access_denied”,“error_description”:“You just logged in with a user who does not belong to domain . Please try logging in with an administrator user of the domain.”}

On the google side, I have added myself and another email as test users, wonder where in the configuation I need to change to make this work.

1 Like

It appears that the error message you received is related to the user account you used to log in with not being recognized as an administrator user in the domain. You may need to check your Google Workspace settings and ensure that the user account you are using to log in with has the necessary permissions to access the app. Additionally, you may want to double-check that the test users you added to the domain are correctly configured and have the proper permissions to access the app as well. If you continue to experience issues, you may want to reach out to Google Workspace support or Auth0 support for further assistance try this if it helps you.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.