Auth0 Home Blog Docs

Real time webtask logs not working

Hi All,

I’m trying to do a simple post request in a Hook to an API endpoint (SendGrid) and I’m getting the following error when running it in the hook.

    {
  "message": "Body.context received by extensibility point is not an object",
  "statusCode": 500,
  "stack": "Error: Body.context received by extensibility point is not an object\n    at Authz.is_authorized.error (/data/sandbox/node_modules/auth0-ext-compilers/lib/compilers/user-registration.js:21:23)\n    at Object.is_authorized (/data/sandbox/node_modules/auth0-ext-compilers/lib/authorization.js:13:81)\n    at userRegistrationHandler (/data/sandbox/node_modules/auth0-ext-compilers/lib/compilers/user-registration.js:9:18)\n    at parseBody (/data/sandbox/node_modules/auth0-ext-compilers/lib/adapter.js:90:20)\n    at finish (/data/sandbox/node_modules/auth0-ext-compilers/node_modules/wreck/lib/index.js:369:16)\n    at wrapped (/data/sandbox/node_modules/auth0-ext-compilers/node_modules/hoek/lib/index.js:879:20)\n    at module.exports.internals.Recorder.onReaderFinish (/data/sandbox/node_modules/auth0-ext-compilers/node_modules/wreck/lib/index.js:415:16)\n    at Object.onceWrapper (events.js:313:30)\n    at emitNone (events.js:111:20)\n    at module.exports.internals.Recorder.emit (events.js:208:7)"
}

So I’ve installed the Real-time webtask log extension to debug the hook but all I see in the extension or the hook logs is the following:

28

I’ve been trying to debug a simple post request now for hours and beginning to pull my hair out especially as I know the post code works in a node application which I’ve tested in.

Thanks,
Tom

Hi @gintomm,

I have a few questions and initial suggestions for you to try when you boot up the Real-Time Webtask Log.

  • Are you receiving any errors in the browser console?
  • Try logging out of Auth0 and logging back in.
  • Try uninstall/reinstall the extension.
  • Try on a different browser.
  • Try incognito/private browsing mode if possible.

Finally, if none of these make any tangible difference, then please capture a HAR and send it to me in a DM.

Thanks,
Dan

Hi @dan.woda,

So I tried the suggestions below and unfortunately nothing worked so I’ll send you over the HAR file

  1. Nope there are no errors in the console log
  2. Logged out and back in - didn’t work
  3. Uninstalled and reinstalled 3 times - didn’t work
  4. Tried Chrome, Firefox & Safari - didn’t work
  5. Tried incognito mode - didn’t work

Thanks,
Tom

@gintomm,

Okay, sorry that didn’t do it. Looking at the HAR now.

Dan

Okay, the HAR isn’t revealing anything. I got a second opinion on this, and have a couple more questions.

  • Could you reply with the post request you are making to send grid(with sensitive data scrubbed out) or send it to me in a DM? Take a look at this topic as well.
  • To clarify, are you using the hooks editor console logging or the webtask log extension?

Thanks,
Dan