Auth0 Home Blog Docs

Node 8 Migration - Real-time Webtask Logs not working

webtask

#1

I’ve just updated my tenant to use Node 8 and have noticed that log messages in Rules are no longer appearing in the Real-time Webtask Logs extension. The code is still running under Node 8 as I can log in to my application successfully, I suspect it is the logging which isn’t working. Changing back to Node 4 causes the log messages to appear again.

Is there an issue with this extension caused by the Node 8 migration? Is anyone else seeing an issue with log messages


#2

We had an issue on this earlier today - and it is now resolved. For more info, the status page link is here: http://status.auth0.com/incidents/77gg0xqtvqd5


#3

@jeremy.meiss @chrisbradley I’m still having a problem with this. The logs are not working for me and I cannot see any console messages.
I’ve also noticed that the new “Extensibility” panel is no longer available so I cannot change back to Node 4. Any ideas?

Many thanks.


#4

@hesperanca @chrisbradley there was a recently published version of the Realtime Webtask Logs Extension. Please update, and that should fix your problem.


#5

Thanks for your reply. Unfortunately the upgrade is not working, I click on the “Update to 1.2” and it says updating, but, when I come back to the page it still says that the installed version is 1.1. Tried a few times.


#6

Just a quick update…removed the extension and installed it from scratch and it worked. Logs back again :slight_smile: